Settlement Delays
Incident Report for Payrix Integrated
Resolved
This issue has now been resolved.
Posted Apr 29, 2022 - 11:34 AEST
Monitoring
There was an unforeseen issue with our Payment Provider yesterday, the issue has been rectified and payments have been pushed through today, clients will receive settlement today up to and including midnight.
Posted Apr 29, 2022 - 11:19 AEST
This incident affected: Reporting and Settlement.